MantisBT

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000219WebSolarLog[All Projects] Generalpublic2014-03-05 20:322014-03-19 21:02
Reportersye79 
Assigned Tomfrijmann 
PrioritylowSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformRPIOSOS Version
Product Version 
Target VersionFixed in VersionRelease 1.1.0 
Summary0000219: Daily mail report
DescriptionSince a couple of weeks now I no longer receive mails about the harvested KWs.

If i send a testmail it works.

I think this service has been decomissioned with another request about unwanted mails (i.e. start up mails, u.v. warnings), but this was a wanted mail :)

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000346)
mfrijmann (administrator)
2014-03-05 22:34

Just tested it with some custom code on my localhost and i recieved a shutdown email;
============================================
Your inverter Aurora Uno 2.5 is done for the day.

These are the figures of the day:

Energy: 9,577 kWh
Max: 1554 Watt (13:44)
============================================

So for now i don't see any problems.

I added some debugging code to the class that handles the sendEmail.
It should now log to wsl.log, so please check the logfile after sundown and see if you could find an line that start with (without the quotes):
"SendEmail error:"


Could you also give me some more information about your WSL installation?
- With how many inverters are you working
- Do you use a smartMeter?
- other things that i need to know about your install
(0000348)
sye79 (reporter)
2014-03-06 12:02
edited on: 2014-03-06 12:03

- 1 inverter
- No smartMeter
- Pretty basic install with two strings connected to 1 PVI 3.6 (max output 4.08KWp)

I've updated to the latest trunk (1736) and I've sent a testmail, but nothing shows up in wsl.log concerning "sendmail"

========================================
20140305 200002 info onInfo - Janitor starts cleaning.
20140305 210005 info onInfo - Janitor starts cleaning.
20140305 220004 info onInfo - Janitor starts cleaning.
20140305 230005 info onInfo - Janitor starts cleaning.
20140306 000001 info onInfo - Janitor starts cleaning.
20140306 001504 error onError - PVoutput::saveTeamStateFromPVoutputToDBOODB S$
20140306 010000 info onInfo - Janitor checking the database.
20140306 010006 info onInfo - Janitor starts cleaning.
20140306 020003 info onInfo - Janitor starts cleaning.
20140306 030002 info onInfo - Janitor starts cleaning.
20140306 040003 info onInfo - Janitor starts cleaning.
20140306 050006 info onInfo - Janitor starts cleaning.
20140306 060004 info onInfo - Janitor starts cleaning.
20140306 070003 info onInfo - Janitor starts cleaning.
20140306 072519 debug onInverterStartup - SYE_Aurora
20140306 080002 info onInfo - Janitor starts cleaning.
20140306 090003 info onInfo - Janitor starts cleaning.
20140306 100002 info onInfo - Janitor starts cleaning.
20140306 110002 info onInfo - Janitor starts cleaning.
20140306 113110 info onInfo - Starting update
20140306 113111 info onInfo - Update info: Starting checkout of http://svn.c$ [^]
20140306 113118 info onInfo - Update info: Removing old files and copy new f$
20140306 113122 info onInfo - Update ready: trunk (1736)
20140306 113209 info onInfo - Janitor checking the database.
20140306 120010 info onInfo - Janitor starts cleaning.
========================================


I've sent testmails before and after the trunk update.

(0000349)
mfrijmann (administrator)
2014-03-06 12:47

The debug line should only appear when:
1. WSL sends an "end of the Day report email"
2. When there is An error while sending the email.

So please wait till the sun is down for half an hour and then check wsl.log and see ik you can find the line.
(0000350)
mfrijmann (administrator)
2014-03-06 23:15

Did you receive the email OR did you found some debugging in wsl.log?
(0000351)
sye79 (reporter)
2014-03-07 09:27

20140306 180003 info onInfo - Janitor starts cleaning.
20140306 190001 info onInfo - Janitor starts cleaning.
20140306 190242 debug onInverterShutdown - SYE_Aurora
20140306 190245 error onError - SendEmail error: The following From address failed:
(0000354)
sye79 (reporter)
2014-03-07 09:43

Apparently my output isn't saved anymore too
(0000355)
sye79 (reporter)
2014-03-07 10:18

Ha graphics are working again...don't know what happened, but refreshed graphs and now it is showing correctly.
(0000356)
mfrijmann (administrator)
2014-03-07 15:03

Strange!

Yesterday I configured my WSL to send "daily reports" and also didn't receive it.
I just added some more debugging for this issue and will see what i can find on this issue!
(0000357)
sye79 (reporter)
2014-03-08 09:07

Reveived this error message while trying to send. Changed my email for antispam purposes

=============================================
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

  user@email.com
    local delivery failed

The following text was generated during the delivery attempt:

------ user@email.com ------

An error was detected while processing a file of BSMTP input.
The error message was:

  421 Lost incoming connection

The SMTP transaction started in line 0.
The error was detected in line 3.
0 previous messages were successfully processed.
The rest of the batch was abandoned.
421 Lost incoming connection
Transaction started in line 0
Error detected in line 3

------ This is a copy of the message, including all the headers. ------

Return-path: <user@email.com>
Received: from mail.axc.nl ([159.253.0.157]:45570)
    by vserver61.axc.nl with esmtp (Exim 4.82)
    (envelope-from <user@email.com>)
    id 1WMBr5-0001ly-3h
    for user@email.com; Sat, 08 Mar 2014 08:39:35 +0100
Date: Sat, 8 Mar 2014 08:39:34 +0100
To: user@email.com
From: Solar Power <user@email.com>
Subject: WSL :: Error message
Message-ID: <46d0bf73590b005816fc2c722196475f@localhost>
X-Priority: 3
X-Mailer: PHPMailer 5.2.2 (http://code.google.com/a/apache-extras.org/p/phpmailer/ [^])
MIME-Version: 1.0
Content-Transfer-Encoding: 8bit
Content-Type: text/html; charset=iso-8859-1

Hello,



WebSolarLog experienced an error.



SendEmail; Everything looks ok!


Please check if everything is alright.

WebSolarLog
=============================================
(0000358)
mfrijmann (administrator)
2014-03-08 10:00

OK!
That looks good and i know; that sounds crazy :D

Yesterday i added some debugging on the sendmail and one of them was sending a error message when sending a email didn't return a error. So in your case sending an email when as aspect and that was confirmed by this email.

I believe you will, next evening,receive the "end of the day report" email again.

Please let me know!
(0000359)
sye79 (reporter)
2014-03-09 08:59

Did not receive anything yesterday evening. But I still was on Trunk 1763 and I saw there was already a newer one. Will update and try again. Keep you posted
(0000361)
sye79 (reporter)
2014-03-10 13:36

No mails yet (trunk 1765)
(0000364)
bpbuster (reporter)
2014-03-12 23:57

I have also lost this functionality for about a month. An update to trunk 1765 has not fixed this.

Test emails work fine

Receive alarms: is unchecked
Receive events: is unchecked
Receive reports: is checked
(0000365)
mfrijmann (administrator)
2014-03-15 09:42
edited on: 2014-03-15 09:43

Any mails yet?

Yesterday i received some error mails, so that indicates that the mail functionalty is working. But i don't receive report emails.

The last trunks i added some more debug lines and in my cases it very strange;
20140314 191431 debug onInverterShutdown - PowerOne4.2
20140314 191431 debug onDebug - MailAddon::onInverterShutdown::End day Report:: Inverter Shutdown
20140314 191431 debug onDebug - MailAddon::onInverterShutdown::End day Report::args::Array ( [0] => onInverterShutdown [1] => Device Object( ***removed***) )
20140314 191431 debug onDebug - MailAddon::onInverterShutdown::End day Report:: Config says; you may send!
20140314 191434 debug onDebug - Common::sendMail::Starting with function sendMail()
20140314 191434 debug onDebug - Common::sendMail::SendEmail error: The following From address failed: ***@***.***

As far i'm gettings it;
- WSL is reports the inverter is down
- then we go to end day report for shutdown inverter
- the report function is getting the necessary arguments to run
- the config says that we may send a email
- going to the sendMail function
- then we get error that the mail adres is failed...

To me this looks like a mail-provider issue, but i can't see anythings strange in my mailaccount.

The piece of logging can be found in /log/wsl.log and about half an hour after the sundown time. i'm very curious to see your logging so we could see if we can find the problem this way.

(0000366)
wimlem (reporter)
2014-03-16 15:31

for me the same issue and no events in the log;
20140315 190226 debug onInverterShutdown - Soladin 600
20140315 191144 debug onInverterShutdown - Power-One 3.0
20140315 200005 info onInfo - Janitor starts cleaning.

I'm using Xs4all. Test e-mails are working..
(0000368)
wimlem (reporter)
2014-03-18 19:12

with trunk 1793;

Your inverter Soladin 600 is done for the day.

These are the figures of the day:

Energy: 0.4 kWh
Max: 158 Watt (14:09)

Seems to be working again!
(0000369)
mfrijmann (administrator)
2014-03-18 19:21

ooo yeah!!

Just received it :D

------------------------------------------
Your inverter PowerOne4.2 is done for the day.

These are the figures of the day:

Energy: 4.736 kWh
Max: 3034 Watt (15:22)
(0000370)
sye79 (reporter)
2014-03-19 09:24

Joy Joy!!

Did not receive anything yet, but was still on trunk 1790 yesterday evening.
Just upgraded to 1793, so I am expecting :)
(0000371)
mfrijmann (administrator)
2014-03-19 09:36

Commit 1732 contains the changes that should solve it (and did in my case).
So if your experiencing mail problems, please update to 1732.
(0000374)
sye79 (reporter)
2014-03-19 19:29

Your inverter SYE_Aurora is done for the day.

These are the figures of the day:

Energy: 14.932 kWh
Max: 3222 Watt (12:13)



Thank you mr Frijman :-)
(0000375)
mfrijmann (administrator)
2014-03-19 21:02

Your welcome!

- Issue History
Date Modified Username Field Change
2014-03-05 20:32 sye79 New Issue
2014-03-05 22:30 Changeset attached => SourceForge trunk r1732
2014-03-05 22:34 mfrijmann Note Added: 0000346
2014-03-06 12:02 sye79 Note Added: 0000348
2014-03-06 12:03 sye79 Note Edited: 0000348 View Revisions
2014-03-06 12:47 mfrijmann Note Added: 0000349
2014-03-06 23:15 mfrijmann Note Added: 0000350
2014-03-07 09:27 sye79 Note Added: 0000351
2014-03-07 09:29 sye79 Note Added: 0000352
2014-03-07 09:38 sye79 Note Added: 0000353
2014-03-07 09:41 sye79 Note Deleted: 0000353
2014-03-07 09:41 sye79 Note Deleted: 0000352
2014-03-07 09:43 sye79 Note Added: 0000354
2014-03-07 10:18 sye79 Note Added: 0000355
2014-03-07 15:03 mfrijmann Note Added: 0000356
2014-03-07 15:15 Changeset attached => SourceForge trunk r1755
2014-03-07 21:45 Changeset attached => SourceForge trunk r1762
2014-03-07 22:30 Changeset attached => SourceForge trunk r1763
2014-03-08 09:07 sye79 Note Added: 0000357
2014-03-08 10:00 mfrijmann Note Added: 0000358
2014-03-09 08:59 sye79 Note Added: 0000359
2014-03-10 13:36 sye79 Note Added: 0000361
2014-03-12 23:57 bpbuster Note Added: 0000364
2014-03-13 09:00 Changeset attached => SourceForge trunk r1773
2014-03-15 09:42 mfrijmann Note Added: 0000365
2014-03-15 09:43 mfrijmann Note Edited: 0000365 View Revisions
2014-03-16 15:31 wimlem Note Added: 0000366
2014-03-18 16:00 Changeset attached => SourceForge trunk r1793
2014-03-18 19:12 wimlem Note Added: 0000368
2014-03-18 19:21 mfrijmann Note Added: 0000369
2014-03-19 09:24 sye79 Note Added: 0000370
2014-03-19 09:36 mfrijmann Note Added: 0000371
2014-03-19 19:29 sye79 Note Added: 0000374
2014-03-19 21:02 mfrijmann Note Added: 0000375
2014-03-19 21:02 mfrijmann Status new => resolved
2014-03-19 21:02 mfrijmann Fixed in Version => Release 1.1.0
2014-03-19 21:02 mfrijmann Resolution open => fixed
2014-03-19 21:02 mfrijmann Assigned To => mfrijmann


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker