MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000161WebSolarLogServicespublic2013-10-31 17:422014-03-05 08:57
Reporterdutchandre 
Assigned Tomfrijmann 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in VersionRelease 1.1.0 
Summary0000161: From trunk 1272 on reporting to pvoutput doesn't work
DescriptionWhen a trunk is installed (1272 or newer) it doesn't report to pvoutput.
This is only valid on the Dutchandre hosted WSL, on my local Rpi it reports fine.
When the stable release is installed this problem doesn't happen.
The only thing I noticed is that sqlite is not loaded.
Because this WSL is hosted I can't debug it.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000217)
mfrijmann (administrator)
2013-10-31 21:26

Does it report nothing or incorrect data?
Could you provide a link to a PVoutput day which shows this?
(0000218)
dutchandre (reporter)
2013-11-02 01:01
edited on: 2013-11-02 01:03

I thought you could find my pvoutput by searching 'dutchandre'.
A link is more easy http://www.pvoutput.org/intraday.jsp?id=16636&sid=14419 [^]
It doesn't report anything, the only thing possible for me is install the stable.
Wsl itself connects to the Diehl and shows all data like normal.
The Diehl demo runs a trunk also but it is older then the 1272.
As far as I know the demo doesn't report to pvoutput.
I like the trunk more because it reports weather data.

(0000220)
mfrijmann (administrator)
2013-11-02 09:11

The DiehlDemo is updating to trunk 1374.
So we could see whats happening and hopefully find the problem.
(0000222)
dutchandre (reporter)
2013-11-02 10:36

I've updated to this trunk too and it doesn't update my pvoutput, the last update was 10:05 running the Wsl stable.
I'll change the Wsl pw to standard.
(0000224)
wimlem (reporter)
2013-11-10 22:34

My update to pvoutput.org stopped too. My last update was on 7-11.
(0000225)
mfrijmann (administrator)
2013-11-11 08:37

Just added some debugging code.
Could you (wimlem) update your WSL so i could see whats happening?
(0000226)
wimlem (reporter)
2013-11-11 08:51

I did the update ;-)
(0000227)
mfrijmann (administrator)
2013-11-11 09:44

Think i got him....
Could you update again?
(0000228)
wimlem (reporter)
2013-11-11 09:49

yep. i'm now on trunk 1396.
(0000229)
wimlem (reporter)
2013-11-11 10:03

Seems to work again. PvO is getting filled.
(0000230)
mfrijmann (administrator)
2013-11-11 10:11

Looked at your PVoutput and indeed it filling again :)

DutchAndré, could you also update to see if this solves your problem to?
(0000231)
dutchandre (reporter)
2013-11-11 10:22

Well I think I'm special :(
Wsl works fine but there's still no logging to pvoutput ...
Maybe sqlite3 old version is the problem?

Watch pvoutput http://www.pvoutput.org/intraday.jsp?id=16636&sid=14419 [^]
It stops at 10:00 when I updated to this trunk.
(0000295)
mfrijmann (administrator)
2014-02-22 11:20

Could this one be closed?
(0000303)
dutchandre (reporter)
2014-02-22 11:43

No, I've seen it also on my own Rpi logging EpeSolar.
With the newer trunks like 1641 it grows worse, it stops logging to pvoutput 30 to 45 minutes to early.
The power on the Diehl is sometimes 80W when the logging stops.
As a result I fill in the last value on pvoutput myself to correct it.
WSL does count the same as the Diehl.
(0000304)
mfrijmann (administrator)
2014-02-22 11:45

hmm.... that sounds terrible! we will soon take a look at it.
(0000305)
mfrijmann (administrator)
2014-02-22 11:53
edited on: 2014-02-22 11:54

Please see the new PVoutputData Admin page in Admin::Devices::YourDevice>PVoutputdata.

Here you can see what WSL is doing with the records and you could see for yourself what is happening "under the hood".

Edit;
O i realise that this is only available in the latest trunk... Hopefully you trust our work and you would consider a update to the latest trunk.

(0000307)
dutchandre (reporter)
2014-02-22 12:03
edited on: 2014-02-22 12:05

To be clear, this 30-45 minutes is only the Dutchandre, not the EpeSolar.
EpeSolar only misses the last 1 or 2 Watts.
That new option is nice, I'll try the last trunk soon.

(0000308)
mfrijmann (administrator)
2014-02-22 12:11

EpeSolar is from and on which trunk?
DutchAndre is on which trunk?

The last days we made a few changes on the PVoutput upload for multi inverters and smashed some bugs.

my advice would be to update to the latest trunk and see if the PVo behavior is better.
(0000309)
dutchandre (reporter)
2014-02-22 13:12

They both were on 1641, now they are on 1665 and they seem to work fine.
Btw, EpeSolar on my Rpi was stalled this night so it misses data until 11:50.
When I run 2 Diehls on my Rpi the EpeSolar works but my Diehl gets no data at all.
There is al Live line on the dashboard and the debuglog shows errors like undefined variable and unknown array.
(0000313)
dutchandre (reporter)
2014-02-23 12:17

Today the 'lost' data was added to pvoutput, so it isn't lost but delayed :-)
The strange thing is that it happens when the inverter is still on ...
About the original 1W issue, that is a lost Watt being not added next day.
(0000334)
mfrijmann (administrator)
2014-02-28 12:56

How did it go for the last days?

- Issue History
Date Modified Username Field Change
2013-10-31 17:42 dutchandre New Issue
2013-10-31 21:26 mfrijmann Note Added: 0000217
2013-11-02 01:01 dutchandre Note Added: 0000218
2013-11-02 01:03 dutchandre Note Edited: 0000218 View Revisions
2013-11-02 09:11 mfrijmann Note Added: 0000220
2013-11-02 10:36 dutchandre Note Added: 0000222
2013-11-10 22:34 wimlem Note Added: 0000224
2013-11-11 08:37 mfrijmann Note Added: 0000225
2013-11-11 08:51 wimlem Note Added: 0000226
2013-11-11 09:44 mfrijmann Note Added: 0000227
2013-11-11 09:49 wimlem Note Added: 0000228
2013-11-11 10:03 wimlem Note Added: 0000229
2013-11-11 10:11 mfrijmann Note Added: 0000230
2013-11-11 10:22 dutchandre Note Added: 0000231
2014-02-22 11:20 mfrijmann Note Added: 0000295
2014-02-22 11:20 mfrijmann Assigned To => mfrijmann
2014-02-22 11:20 mfrijmann Status new => feedback
2014-02-22 11:43 dutchandre Note Added: 0000303
2014-02-22 11:43 dutchandre Status feedback => assigned
2014-02-22 11:45 mfrijmann Note Added: 0000304
2014-02-22 11:53 mfrijmann Note Added: 0000305
2014-02-22 11:54 mfrijmann Note Edited: 0000305 View Revisions
2014-02-22 12:03 dutchandre Note Added: 0000307
2014-02-22 12:05 dutchandre Note Edited: 0000307 View Revisions
2014-02-22 12:11 mfrijmann Note Added: 0000308
2014-02-22 13:12 dutchandre Note Added: 0000309
2014-02-23 12:17 dutchandre Note Added: 0000313
2014-02-28 12:56 mfrijmann Note Added: 0000334
2014-02-28 12:59 mfrijmann Relationship added related to 0000212
2014-03-05 08:57 mfrijmann Status assigned => resolved
2014-03-05 08:57 mfrijmann Fixed in Version => Release 1.1.0
2014-03-05 08:57 mfrijmann Resolution open => fixed
2014-03-06 13:10 mfrijmann Relationship deleted related to 0000212


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker