MantisBT - WebSolarLog
View Issue Details
0000236WebSolarLog[All Projects] Generalpublic2014-03-21 08:202014-08-21 18:43
sparky 
 
normalminoralways
newopen 
 
 
0000236: Off by one error with reporting at month borders
There is an off by one error that occurs at month borders. The last day of the month counts toward the next month's tally in certain areas (but not all). This might be related to issue 0000235
No tags attached.
png WSL_month_boundry_error.png (174,153) 2014-04-01 07:48
http://tracker.websolarlog.com/file_download.php?file_id=33&type=bug
png

png WSL_month_boundry_error_2.png (106,989) 2014-04-01 07:54
http://tracker.websolarlog.com/file_download.php?file_id=34&type=bug
png
Issue History
2014-03-21 08:20sparkyNew Issue
2014-03-22 06:46sparkyNote Added: 0000392
2014-03-22 06:47sparkyNote Edited: 0000392bug_revision_view_page.php?bugnote_id=392#r117
2014-04-01 07:48sparkyFile Added: WSL_month_boundry_error.png
2014-04-01 07:49sparkyNote Added: 0000428
2014-04-01 07:54sparkyFile Added: WSL_month_boundry_error_2.png
2014-04-01 07:55sparkyNote Edited: 0000428bug_revision_view_page.php?bugnote_id=428#r140
2014-04-01 13:35mfrijmannNote Added: 0000429
2014-04-05 21:27sparkyNote Added: 0000432
2014-08-21 18:43mfrijmannNote Added: 0000490

Notes
(0000392)
sparky   
2014-03-22 06:46   
(edited on: 2014-03-22 06:47)
Here is an example. When looking at the month view, my cumulative tally for the month is 123.119kWh. When looking at the production page, I see I have harvested 126kWh. When I look at the top page (as well as Dashboard), the "Some Figures*" summary table along the right edge says I have 126.18kWh for the month of March. As it turns out, I harvested 3.06kWh on February 28th - which accounts for the discrepancy. When the tallies for the month of March are complete, March 31st will count toward the month of April.

This problem applies to the yearly totals as well. December 31st is tallied as part of the year that starts the following day.

(0000428)
sparky   
2014-04-01 07:49   
(edited on: 2014-04-01 07:55)
Uploaded a screenshot of the dashboard for March 31st. Note that the month tally has been reset and only includes today's production.

Also uploaded a photo of the production page. Note that there are now two lines for March and none for April.

(0000429)
mfrijmann   
2014-04-01 13:35   
could you send me your wsl database?
(0000432)
sparky   
2014-04-05 21:27   
database sent. Let me know if you didn't get it.
(0000490)
mfrijmann   
2014-08-21 18:43   
Sorry for the late response.
I looked at your database and can't find any strange thing.
Also i connected your database to the latest trunk release and see no strange things.

Do you have still this issue?